POC, der mp3 Streamer

In letzter Zeit arbeite ich wieder ein bisschen an meinen ganzen MP3-Tools, unter anderem weil mir vorschwebt, in nächster Zeit ein Saugnapf-Podcast zu machen. Und da kommt es oft vor, dass ich mir ein kleines Stück aus einem grossen MP3 raussplitten muss. Die meisten MP3-Tools die es so gibt, packen das nicht, auf das Bit-Reservoir bei MP3-Frames zu achten, so dass die geschnittenen MP3s dann knarzen und fiepen und generell kaputt sind (siehe dazu auch die Erklärung in RFC 3119). Nebenbei angemerkt: der Algorithmus in RFC 3119 zum Extrahieren von ADUs ist leicht kaputt, meine Implementierung in poc müsste aber korrekt sein (zumindest wurde dies “empirisch” belegt :).

Gestern wurde also die Version 0.4.0 von poc released, diesmal mit ID3 Tag Support für mp3cue, und ein neues Tool namens mp3cut, dass es ermöglicht, von der Kommandozeile aus MP3s zu schneiden, und zwar nicht interaktiv (also nach dem Motto “Schneide bitte die 5 erste Minuten raus”). Ob das jetzt wirklich brauchbarer ist als eine GUI ist mir noch nicht wirklich klar. Beim Debuggen habe ich dann auch einen lustigen Bug gefunden. Beim Schneiden von dem submix 027 von Subsource kam ich auf relativ komische Ergebnisse. Mein iTunes sagte mir, dass das Stück, das ich herausschneiden wollte, bei 29:30 anfing. Prompt werfe ich mp3cut an, doch da kommt nicht wirklich das heraus, was ich vorhin gehört habe. Zeigt denn jetzt iTunes die falsche Zeit an, oder ist mein Tool nicht wirklich kosher? Ich vermute natuerlich zuerst, dass mein Tool kaputt ist, und schreibe da ein paar Debugtools. Doch dann komme ich auf die Idee, die 10 ersten Sekunden von dem Submix rauszuschneiden. Nach dem Importieren in iTunes zeigt dieser mir eine Länge von 15 Sekunden an. Aha! Stoppuhr in die Hand, auf Play druecken. Siehe da, die Sekunden von iTunes sind ploetzlich kuerzer geworden. Beim Testen mit anderen Playern waren alle falsch (winamp, xmms, iTunes), nur meine Software nicht. Na super!

Nun aber zu dem eigentlichen Thema von diesem Posting. poc ist eigentlich ein Sammlung von Streamingtools (hauptsächlich für mp3s, aber ogg über HTTP geht schon). Das ursprüngliche Ziel war Streamen über Multicast, und das baut auf UDP auf, so dass es relativ schnell bei bisschen kaputtem Netz zu Packet Loss kommen kann. Die “Standard”-Lösung für Streaming über Multicast ist das Real-Time Transport Protocol, bei dem es zwei genauere Standard für das Streaming von MP3s über RTP gibt: RFC 2250 und RFC 3119. Bei RFC 2250 wird der straightforward Ansatz verwendet: ein Frame pro UDP Paket (so ungefähr). Bei Packet Loss klingt das aber richtig, richtig scheisse. Kennt ihr noch die ganz alten MP3 Player, die noch keine Tags erkennen konnten (z.B. mpg123)? Da hat das dann immer so *quieek* *flutsch* gemacht, oder noch besser, der Player ist ausgestiegen. Genauso klingt RTP RFC 2250, weil MP3 Frames meistens noch Daten aus vorherigen MP3 Frames benötigen. RTP RFC 3119 will das verbessern, und versendet nur ein “ADU” pro UDP Paket. Ein ADU ist ein selbstständiges MP3 Frame, bei der keine Daten aus vorherigen Paketen benötigt werden. Bei Paket Loss kommt es nur zu einem Aussetzer in der Klangwiedergabe, aber nicht zu Fehlern in der MP3 Dekodierung. Keins der beiden Protokoll ermöglicht jedoch das Ausradieren von Packet Loss, so dass ich da ein kleines Protokoll entworfen habe, das mit Forward Error Correction arbeitet, um Packet Loss beim MP3 Streaming zu vermeiden versucht. Dazu habe ich ein Verfahren von Luigi Rizzo eingesetzt, dass auf linearen Operationen basiert, und ein “Erasure Code” ist, also genau geeignet ist, um Packet Loss zu vermeiden. Das Verfahren ist in dem Paper “Effective erasure codes for reliable computer communication protocols” beschrieben.

Im Grossen und Ganzen funktionniert das Streamingverfahren wie folgt: aus einem MP3 Strom werden die ADUs extrahiert (so wie bei RFC 3119 RTP). Diese ADUs werden in Gruppen von k ADUs gruppiert, und aus diesen k ADUs werden anhand des FEC-Verfahrens n Pakete gebildet. Dabei sind die k ersten Pakete die ADUs vom Anfang. Jetzt werden die n Pakete mit einer Sequenznummer versehen und über UDP versendet. Ein Empfänger braucht nur k dieser Pakete zu empfangen, um die k ADUs wieder herzustellen. Es reicht also k von n Pakete zu empfangen, um den Stream lückenlos abzuspielen. Das Coole ist, dass man k und n frei wählen kann, und während des Streamens auch anpassen kann. Ein weiteres cooles Feature ist, dass selbst wenn nicht alle k Pakete empfangen werden können Teile des Streams abgespielt werden können. Wenn die empfangenen Pakete zu den k ersten Paketen der n Paketen gehören (also den original-ADUs gleich sind), können sie wie bei RFC 3119 abgespielt werden. Die jetzigen Tools (poc-fec, der Streamserver, und pob-fec, der Streamclient) haben allerdings keinen eingebauten MP3-Decoder, sondern kleben die empfangenen ADUs wieder zusammen zu einem “korrekten” MP3-Stream, und schreiben diesen auf die Standardausgabe, damit man sie von dort in ein weiteres Tool streamen kann. Das sieht dann so aus:

pob-fec | mpg123 –

oder auch

pob-fec | poc-http –

Das erste leitet die Standardausgabe in das supergrottenschlechte Tool mpg123 um (unter Debian sogar in das noch schlechtere, aber *FREIE* Tool mpg321), das zweite in den HTTP Streamserver um. Das ist aber alles ein bisschen arg viel Overhead, weil der MP3 Decoder dann aus diesem Stream wieder die ADUs rauspopeln muss. Da koennte man sich den Zwischenschritt doch sparen, und deswegen bastel ich gerade an einem integrierten MP3-FEC-Player. Doch dazu mehr in dem nächsten Netzstaub-Posting.

PS: Wie ich gerade gemerkt habe, gibt es zu FEC und RTP FEC neue RFCs: RFC 3452 und ein IETF Draft.

Posted in Programmstaub | Leave a comment

Blonde Nazi-zwillings-teenie-folk-saengerinnen

Es gibt Seiten, die so skuril sind, dass man gleich einen aufwendigen
Fake dahinter vermutet, so wie z.B. diese
Seite
, die eine rassistische Folkband aus dem Dunstkreis des
KKK total hoch-hyped:

These gals will be breaking new ground, and will also capture the imagination of young boys and girls all across the world. The impact could be huge and their influence will encourage ‘copycats’ …creating an entire genre of pro-White music. …I’m hanging on the edge of my seat with anticipation.

Nur dass die Folkband aus zwei 12-Jaehrigen Maedchen besteht, die
langweilige, schlecht gesungene Covers von irgendwelchen
White-Power-Schrammel-Bands machen. Und dazu auf der Gitarre kratzen und
die Fiedel zum jaulen bringen. Auf der National Vanguard sind
dann Auszuege aus einem Interview gepostet, bei denen man sich man
ernsthaft fragt, ob das doch nicht ironisch gemeint sein koennte, und
auch die Seite der Maedchen
nur eine riesige Verarsche ist. Die Band heisst uebrigens “Prussian
Blue”, erstens wegen der preussischen Arier mit blauen Augen (das steht so auf der Seite), aber
auch wegen der blauen Faerbung von Zyklon-B, so dass der Name zum
Nachdenken ueber die “vermutlichen Verbrechen” der Nazis im zweiten
Weltkrieg fuehren sollte. Da fragt man sich, ob man lachen oder
heulen sollte.

Hier ein paar koestliche Auszuege aus dem Interview:
Frage:
What do you think is the most important social issue facing the white
race right now? Do you have any songs that address this issue?
Antwort:
Not having enough white babies born to replace ourselves and generally
not having good-quality white people being born. It seems like smart
white girls who have good eugenics are more interested in making money
in a career or partying than getting married and having a family. And
yes, we are working on some new songs about this issue.
Hoch qualitative Menschen? Ahja…

Frage:
What are some of your favorite groups, either current or past?
Antwort:
We really like Avril Lavigne, Evanescence, Three Days Grace, Green Day, AC/DC,
and Alison Krauss. For racial groups we like Final War, CutThroat, Saga, Max
Resist, Youngland, Brutal Attack, and of course Skrewdriver. But our all-time
favorite is Barney the purple dinosaur!
Zwei Nazi-Teenies die Green Day hoeren? Und muss man die Antwort
jetzt so verstehen, dass Barney
der Dinosaurier
fuer sie der wichtigste White-Power-Musiker ist?

Posted in Uncategorized | Comments Off on Blonde Nazi-zwillings-teenie-folk-saengerinnen

Kurzgeschichten von Anton Tschechow

Alt Tag Added during WordPress Conversion

Kurzgeschichten von Anton Tschechow gibt es hier (ueber das geile Tofu Hut blog gefunden).

Posted in Uncategorized | Comments Off on Kurzgeschichten von Anton Tschechow

Forth

Eine meiner Hackerregeln bis jetzt war, so oft wie moeglich was
umzustellen, damit es einem bloss nicht zu ungemuetlich wird. Zum
Beispiel das Betriebssystem, oder die Programmiersprache. Der
Hintergedanke dabei: keine Aenderungen, und schon klopft der
Mainstream an der Tuer, und bald hat man sich auf irgendwas
festgesetzt, und ist nicht besser als die Java-Drones oder die
Linux-Juenger da draussen. Die letzte grosse Aenderung ist bei mir
jetzt echt einiges her (der Umstieg auf LISP als
Hauptprogrammiersprache vor ein bisschen mehr als einem Jahr), und
soeben hoerte ich die Langeweile an der Tuer klopfen, um mich
abzuholen. Es musste (oder muss) also unbedingt was her. Zum Glueck
stiess ich ueber irgend ein Blog auf die PDF Version von Thinking
Forth
von Leo Brodie.

Forth war schon frueher mal kurz auf meinem Radar aufgetaucht
(schliesslich konnte man damit recht bequem die Suns im
Informatik-Poolraum 0wn3n), aber so wirklich was geworden war es
nicht. Das Konzept der Sprache ist so einfach und kristallklar:
Programme haben zwei Stacks zur Verfuegung, einer fuer Daten, einer
fuer Returnadressen. Reihenfolge von Befehlen, die diesen Stack
manipulieren, kann man unter einem Namen in einer Struktur namens
Dictionary ablegen. Und das wars so ungefaehr (wer es wirklich genau
wissen will, kann ein Blick in den Forth dpANS Standard
werfen). Klingt so ein bisschen nach Assembler fuer eine Stack
Machine, aber eigentlich ist es viel mehr, der Forth-Compiler ist
naemlich auch in Forth geschrieben, und ist interaktiv. Ohne einer
solchen Schnittstelle zum Compiler ist nach LISP die Welt ein
bisschen grau und oede. Das heisst also, das man den Compiler
weitgehend fuer seine eigenen Zwecke benutzen kann. Man kann Woerter
(sprich, Funktionen) definieren, die zur Compile-Zeit aufgerufen
werden. Oder man kann Woerter definieren, die andere Woerter
definieren und sie um bestimmten Code ergaenzen (Macros).

Das Faszinierende an dem Ganzen jedoch ist immer die geringe
Komplexitaet von dem Code. Der Compiler laesst sich in ein paar Zeilen
niederhacken, so wie eigentlich ziemlich alles in Forth. Das fuehrt
auch dazu, dass jeder Forth-Programmierer mindestens einen eigenen
Forth-Compiler geschrieben hat. Ich habe zum Hacken unter Unix gforth benutzt, das
auch ueber ein nettes Interface zu Emacs verfuegt, als Forth ist es
jedoch leicht bloatig. Es gibt ganz ganz viele Forths, die sich als
komplette Programmierumgebung verstehen, mit Editor, Debugger,
und… Betriebssystem. Besonders erwaehnenswert sind hier die
Forth-Varianten von Chuck
Moore
, der Erfinder von Forth. Sein Colorforth ist ein
Betriebssystem-Forth (es gibt aber auch Linux-Ports
(X11 und OpenGL)
und Windows–Ports), mit eigenem
Tastaturlayout (alles schoen minimal, nur 27 Tasten). Ein
interessantes Feature ist das Syntax weitgehend durch Farben ersetzt
wurde: da wird weniger Platz auf dem Bildschirm verbraten. Ein gute
Link-Sammlung zu Colorforth findet man auf dem Quartus Forth-Wiki. Wenn
man das Colorforth startet, ist man erst total verloren, nur so
langsam kommt man da zurecht. Doch was Chuck Moore damit macht, ist
ehrlich faszinierend. Er hat ein CAD-Programm zum Entwerfen von
VLSI-Schaltungen auf einem solchen System programmiert, und wie man an
den Filmen im Streaming Video
Theater
sehen kann, scheint das extrem schnell und maechtig zu
sein (Chuck Moore meint, es waeren nur 500 Zeilen Code (!!)).

Das ganz spannende an Forth ist, dass man eine Stack-Architektur sehr
einfach in Hardware giessen kann (mittlerweile auch in VHDL
Programmieren): auf der Chip-Seite von Ultratechnology gibt es
eine ausfuehrliche Liste von Stack-Rechnern und Forth-Chips. Dort ist
auch das grossartige Buch Stack
Computers
von Philip Koopman verlinkt, in dem die Architektur von
solchen Stack-Rechnern erlaeutert wird.

Jetzt aber wieder zurueck zu Thinking
Forth
. Thinking Forth ist kein Forth Buch in dem eigentlichen
Sinne, sondern ein Buch ueber die “Philosophie” von Forth, und handelt
eher von Software-Technik: wie werden Probleme analysiert und in Code
umgesetzt, wie kann ich meine Software strukturieren, dass ich sie
einfach schreiben kann, und auch einfach anpassen kann, usw… Nur
sind die Ansaetze in Forth schon anders als in herkoemmlichen
Sprachen. Da es kaum Syntax gibt sind die Grenzen zwischen Funktionen,
Datenstrukturen, Kontrollstrukturen ziemlich verwischt, und es braucht
erst einiges, bis man sich da zurecht findet. Zum Glueck ist das Forth
Einfuehrungsbuch von Leo Brodie in HTML umgesetzt worden: Starting Forth (sehr
empfehlenswert). Es steht dem PUSHen und POPen jetzt nicht mehr im
Wege :}

Posted in Uncategorized | Comments Off on Forth

European Common Lisp Meeting

Edi Weitz, der Mensch der hinter so
tollen Libraries wie CL-GD und CL-PPCRE steckt, hat gerade in
einer Mail
angekuendigt, dass dieses Jahr ein European Lisp Meeting in Amsterdam
statt findet, und zwar am 24. April. Der Eintrittspreis von 25 EUR ist total fair, und die Vortragsliste scheint wirklich interessant zu sein.

  • Jans Aasman von Franz wird ueber
    ihren Persistence-Ansatz berichten (da bin ich mal gespannt, unser bknr datastore ist mittlerweile schick,
    moppig und wirklich brauchbar)
  • Luke Gorrie wird ueber SLIME berichten
  • Antonio Leitao wird ueber linj berichten. Linj ist ein Lisp (bzw. ein Subset von Lisp) Compiler nach Java, der nicht Java-Bytecode produziert (das waer ja langweilig), sondern menschen-lesliches Java produziert. Sowas brauchen wir jetzt unbedingt um Javascript zu produzieren, dieses String-manipulier-kram-zeugs ist wirklich keinem Mensch zuzumuten.
  • Robert Strandh wird ueber Climacs berichten, ein Projekt, dass Emacs nachzubauen wird, und zwar auf CLIM basierend. Und das scheint dieses Mal endlich kein Vaporware zu sein, der Editor scheint anscheinend schon recht brauchbar zu sein.
Posted in Uncategorized | Comments Off on European Common Lisp Meeting

Gabber in die Nacht

Diese Woche soll laut dem Querfunk-Sendungsplan (aber nicht laut
dem Sendungsplan im Internet) die
3. Saugnapf-Sendung am Sonntag von 23:00 bis 24:00 laufen. Ich bin
allerdings ein bisschen dumm, und hatte mich im Januar auf den festen
Rythmus “alle 2 Wochen ist Sendung” eingestellt. Das stimmt natuerlich
nicht, die Sendung laeuft jeden 2. und 4. Sonntag im Monat, und der
Kalender ist nun mal so, dass zwischen der zweiten Sendung und
der dritten
Sendung
eigentlich drei Wochen liegen. Das habe ich jedoch erst
durch einen Zuhoereranruf am letzten Sonntag erfahren, den anstatt
unser ohrenbluteninduzierenden “Death Metal und Gabber
Spezial”-Sendung haette eigentlich eine vorproduzierte “Jazz in die
Nacht”-Sendung laufen sollen. Da haben wohl ein paar Leute nicht so richtig gut einschlafen koennen.

Unserem Motto “Saugnapf zieht dir die beste Musik aus dem Netz”
haben wir in dieser Sendung nur Musik gespielt, die man sich ohne
Passwort mit einem Webbrowser klicken kann. Irgendwann vor Ewigkeiten
hatte ich in einem Opendir ein paar Tracks von Porphyria (klingt so wie
die Krankheit, ist es aber nicht) gezogen, und die haben dem Geist so gefallen,
dass wir spontan eine “Death Metal”-Sendung angekuendigt
hatten. Leider war das Opendir mittlerweile aus dem grossen Datenozean
verschwunden, und die Suche nach gutem Death-Metal erwies sich nicht
so einfach, wie zuerst angenommen. Wo kriegt man denn so guten Metal
her, der nicht so klingt, als haetten ein paar Teenager die
Distortion-Pedale auf Anschlag gedreht und dazu in ein schepperndes
Mikro gejault? Doch nach einigen Umwegen ueber mp3.de und Konsorten stiess ich auf die
Seite purevolume.com, auf der
sich einiges an coolen, scheppernden und kreischenden Bands
angesammelt hat. Dort gibt es wirklich fuer jeden Schwermetaller was,
unter anderem haben wir christlichen
Death-Metal
, Lovecraft-Metal,
Speedcore
und wie auch immer das ganze Geschrammel heisst gespielt. Und ein paar
Tracks von Teenager-Bands
mit aufgedrehten Verstaerkern
waren auch dabei.

Was hat auf den Plattencovern genauso viele Totenschaedel wie
Death-Metal-Scheiben, hoert sich fuer Menschen ueber 30 genauso
schlimm an, und wirft mit XXX-Core begriffen um sich, ist aber kein
Metal? Na klar, Gabber! Deswegen durfte bei unserem “Death Metal
Spezial” auch kein guter, durchhaemmernder
Hardcore-Gabber-Grindcore-Utz-Utz fehlen. Angesichts der richtig
schlimmen Sachen die man bei der Gabba-Front Berlin (oder noch
besser, bei der Gabber-Front
Karlsruhe
) finden kann, haben wir uns doch ein bisschen
zurueckgehalten, und eher niedlich-melodische Tracks wie Steroids
von Jinx gespielt. Bei der Gabba-Front Berlin sind Tracks wie 30
Stunden Schmerz herzlichst zu empfehlen. Uebrigens die erste Seite,
bei der die Songs nicht nach Guete, sondern nach BPM bewertet
werden. BPM fuer 30 Stunden Schmerz: 330. Na dann, die Saugnapf-Crew
wuenscht ihnen einen erfreulichen Herzinfarkt.

Posted in Uncategorized | Comments Off on Gabber in die Nacht

Saugnapf

Die bl0rg-crew hat jetzt alle 2
Wochen
eine Sendung auf querfunk. Erm,
nein, nicht alle 2 Wochen, sondern am 2. und 4. Sonntag im Monat, wie
uns am letzten Sonntag bewusst wurde. Noch genauer gesagt, am 2. und
4. Sonntag im Monat von 23:00 bis 24:00. Die Sendung heisst Saugnapf, und die zieht dir die
feinste Musik aus dem Netz. Reinster Ohrenschmaus.

Die Sendung hat folgendes Konzept: wir spielen Musik, die man ohne
Passwort mit einem Webbrowser aus dem grossen Internet runterladen
kann. In der ersten
Sendung
(Torrent
hier
auf unserem feinen bl0rg-tracker), die auf dem
allerletzten Druecker ein paar Minuten zuvor im Entropia geklickt
wurde, haben wir deswegen hauptsaechlich Netlabel-Electro-Musik
gespielt, in den naechsten Sendungen wurde es dann ein bisschen
recherchierter.

In der zweiten
Sendung
ging es um 8-bit Musik, also alles, was auf
Maschinen zusammengestoepselt wurde, bei denen die Register nur 8
kleine Bits halten konnten. Zum Beispiel Gameboys, oder C64er, oder
VC-20s. Da alles wieder so ein bisschen zur
Klickorgie-der-letzten-Stunde ausgeartet ist, aehnelte die Sendung
zuerst eher dem Soundtrack einer Demoparty. Der Suchalgorithmus, den wir
als halb-biologische-Downloadwesen durchfuehrten, lautete in etwa:

  • Suche Demoparties in chronologischer Reihenfolge auf ftp.scene.org
  • Suche Chiptune-Compo
  • Zieh den Gewinnertrack von dieser Chiptune-Compo

Beim Rumwuehlen in der MOD-Kiste konnte ich dann Aquarium
People
wiederfinden, von Antti A Mikkonen. Aquarium People ist so
ein total grooviges, funkiges kleines Jazz-MOD, das mich frueher immer
ziemlich fasziniert hat. Wahrscheinlich, weil es eins der wenigen MODs
war, die nach Musik mit “richtigen” Instrumenten geklungen
haben. Antti A Mikkonen hat inzwischen seinen Namen gewechselt, und
heisst Aleksi Eben (aka Heatbeat), und ist anscheinend immer noch
aktiv. Das Netlabel monotonik hat eine ganz
grossartige Seite ueber ihn
, auf der er seine
Lieblings-MODs vorstellt, und noch ganz viel knarzige 8-bit Wellen aus
seiner Musikschrank hervorzaubert. Zum Beispiel dieses Gameboy-Jazz-Lied.
Auf
dem Track verleihen die typischen *klaks*-*klaks* Gerauesche des
Gameboys dem Walking Bass den noetigen Drive, und die
Schlachzeugsimulation des billigen Synthesizers klingt fast nach den
schlechten Wachsaufnahmen aus den New-Yorker Jazz-Clubs der 40er.

Auf der Suche nach weiteren Gameboy-Tracks bin ich dann auf die Gameboymusic
Community
bei Livejournal
gestossen. Die Community ist so eine Art Forum, oder eher, ein Weblog
mit verschiedenen Autoren, bei denen Links zu Gameboymusic, oder auch
Ankuendigungen von Plattenreleases oder Konzerten gepostet
werden. Dort kann man die skurrilste Musik finden, wie z.B. dieser Remix von
Flavor
, mit trashigen Gameboysounds als Hiphop-Beat. Ueber die
Community bin ich dann auch auf Bud
Melvin
gekommen, der (achtung!) Country mit Banjo, Steel Guitar,
und… Gameboy macht. Lieder wie Mood Indigo zaubern
dann kuriose Bilder hervor: es ist Sonnenuntergang in der Death
Valley, die Sonne schimmert rot auf die gewaltigen Felsberge, unten
ein Lagerfeuer, ein Cowboy singt mit einerlicher Stimme von seinem
langen Weg nachhause, und waehrenddessen spielt Billy The Kid in einer
dunklen Ecke Supermario.

Continue reading →

Posted in Musikstaub | Comments Off on Saugnapf

Und wieder da

Es ist ja einiges her, fast ein Jahr, dass ich hier was gepostet habe. Aber die Blog-Wut hat mich wieder gepackt, so dass in den naechsten Tagen hier wieder oefter was stehen wird. Freut euch!

Posted in Netzstaub | Comments Off on Und wieder da

Lebst du noch oder postest du schon?

Hallo, was machen Sie denn da? Funktioniert das hier denn alles noch?

Posted in Netzstaub | Comments Off on Lebst du noch oder postest du schon?

hallo hallo?

Ueber 2 Wochen ist es her, dass ich den letzten Eintrag hier verfasst habe, und dabei hatte ich mir so arg vorgenommen, hier regelmaessig (und oft) was zu schreiben. Wir haben jetzt die Welt uebernommen, der LISP-server laeuft so halbwegs, ist meistens nur nicht erreichbar, weil der Router sich nicht richtig bei dyndns eintraegt, aber egal. Die Software wird bald veroeffentlicht, und heisst bknr, als Abkuerzung fuer Baikonour, weil man damit so schoene bunte LISP-Software-Satelliten in den mit Sternen benetzten Computerhimmel schiessen kann. Bald mehr zu den unheimlich tollen Voodoofeatures von bknr 🙂

Posted in Uncategorized | Comments Off on hallo hallo?